Vulnerability CVE-2024-4874


Published: 2024-06-22

Description:
The Bricks Builder plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.9.8 via the postId parameter due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify posts and pages created by other users including admins. As a requirement for this, an admin would have to enable access to the editor specifically for such a user or enable it for all users with a certain user account type.

 References:
https://www.wordfence.com/threat-intel/vulnerabilities/id/6d63e898-43e5-42b5-96b6-1453352e0cae?source=cve
https://bricksbuilder.io/release/bricks-1-9-9/#access-control-fix-for-user-role-contributor

Copyright 2024, cxsecurity.com

 

Back to Top