WikiNi Persistent Cross Site Scripting Vulnerability

2006-05-30 / 2006-05-31
Risk: Low
Local: No
Remote: Yes

CVSS Base Score: 6.8/10
Impact Subscore: 6.4/10
Exploitability Subscore: 8.6/10
Exploit range: Remote
Attack complexity: Medium
Authentication: No required
Confidentiality impact: Partial
Integrity impact: Partial
Availability impact: Partial

Hi, I've found a vulnerability more than 2 months ago, and notified the developers, but still no answer, so I'm posting here. Vendor: WikiNi Vulnerable: WikiNi 0.4.2 and below Persistent Cross Site Scripting A persistent XSS vulnerability is the most dangerous kind of XSS vulnerabilities, as the data submitted by the malicious user is stored permanently on the server. It could potentially hit a large number of other users with little need for social engineering. Just edit a page and insert: ""<script>alert('XSS Vulnerable');</script>"" Restrictions The attacker needs to have the rights to edit at least one page of the wiki, but most of the time it is the case. Moreover, WikiNi 0.4.2 is used on more than 100,000 pages according to Google. --Raphal HUCK

Vote for this issue:


Thanks for you vote!


Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.

(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2024,


Back to Top