XSS vulnerability in TWiki < 5.0.2

2011.05.24
Risk: Low
Local: No
Remote: Yes
CWE: CWE-79


CVSS Base Score: 4.3/10
Impact Subscore: 2.9/10
Exploitability Subscore: 8.6/10
Exploit range: Remote
Attack complexity: Medium
Authentication: No required
Confidentiality impact: None
Integrity impact: Partial
Availability impact: None

Information ----------------------------------- Name : XSS vulnerability in TWiki Software : TWiki 5.0.1 and possibily below. Vendor Hompeage : http://twiki.org/ Vulnerability Type : Cross-Site Scripting Severity : High Researcher : Mesut Timur <mesut [at] mavitunasecurity [dot] com> Advisory Reference : NS-11-005 CVE : CVE-2011-1838 Description ----------------------------------- TWiki&#174; is a flexible, powerful, and easy to use enterprise wiki, enterprise collaboration platform, and web application platform. It is a Structured Wiki, typically used to run a project development space, a document management system, a knowledge base, or any other groupware tool, on an intranet, extranet or the Internet. Details ----------------------------------- TWiki is affected by XSS vulnerabilities in version 5.0.1. Example PoC url is as follows : http://example.com/bin/login?sudo=sudo;origurl=http://example.com/bin/vi ew/Main/TWikiAdminUser%00%27%22--%3E%3C%2Fstyle%3E%3C%2Fscript%3E%3Cscri pt%3Ealert%280x00044C%29%3C%2Fscript%3E http://example.com/bin/login/Main/WebHome?'"1=;origurl=1'"--></style></s cript><script>alert(0x00039C)</script> You can read the full article about Cross-Site Scripting vulnerabilities from here : http://www.mavitunasecurity.com/crosssite-scripting-xss/ Solution ----------------------------------- Upgrade to the latest TWiki version (5.0.2). Credits ----------------------------------- It has been discovered on testing of Netsparker, Web Application Security Scanner - http://www.mavitunasecurity.com/netsparker/. References ----------------------------------- Vendor Url : http://twiki.org/cgi-bin/view/Codev/SecurityAlert-CVE-2011-1838 MSL Advisory Link : http://www.mavitunasecurity.com/XSS-vulnerability-in-Twiki/ Netsparker Advisories : http://www.mavitunasecurity.com/netsparker-advisories/ About Netsparker ----------------------------------- Netsparker&#174; can find and report security issues such as SQL Injection and Cross-site Scripting (XSS) in all web applications regardless of the platform and the technology they are built on. Netsparker's unique detection and exploitation techniques allows it to be dead accurate in reporting hence it's the first and the only False Positive Free web application security scanner. -- Netsparker Advisories, <advisories (at) mavitunasecurity (dot) com [email concealed]> Homepage, http://www.mavitunasecurity.com/netsparker-advisories/

References:

http://twiki.org/cgi-bin/view/Codev/SecurityAlert-CVE-2011-1838
http://www.vupen.com/english/advisories/2011/1258
http://www.securityfocus.com/bid/47899
http://www.securityfocus.com/archive/1/archive/1/518038/100/0/threaded
http://www.mavitunasecurity.com/XSS-vulnerability-in-Twiki/
http://securitytracker.com/id?1025542
http://secunia.com/advisories/44594


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2020, cxsecurity.com

 

Back to Top