Logstash 1.4.2 Directory Traversal

2015.06.10
Credit: Colin Coghill
Risk: Medium
Local: No
Remote: Yes
CWE: CWE-22


CVSS Base Score: 6.4/10
Impact Subscore: 4.9/10
Exploitability Subscore: 10/10
Exploit range: Remote
Attack complexity: Low
Authentication: No required
Confidentiality impact: None
Integrity impact: Partial
Availability impact: Partial

Summary: Logstash versions 1.4.2 and prior are vulnerable to a directory traversal attack that allows an attacker to over-write files on the server running Logstash. This vulnerability is not present in the initial installation of Logstash. The vulnerability is exposed when the file output plugin is configured for use. The files impacted must be writeable by the user that owns the Logstash process. We have been assigned CVE-2015-4152 for this issue. Fixed versions: Versions 1.5.0 and 1.4.3 have addressed the vulnerability. Remediation: Users that currently use the file output plugin or may use it in the future should upgrade to 1.5.0 or 1.4.3. This will address the vulnerability and preserve file output functionality. Users that do not want to upgrade can address the vulnerability by disabling the file output plugin. Credit: Colin Coghill reported this issue. CVSS Overall CVSS score: 4.3


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2017, cxsecurity.com

 

Back to Top