Thomson Reuters FATCA Arbitrary File Upload

2015.08.10
Risk: High
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-264

Title: Thomson Reuters FATCA - Arbitrary File Upload Author: Jakub Pałaczyński Date: 10. June 2015 CVE: CVE-2015-5951 Affected software: ================== All versions of Thomson Reuters FATCA below v5.2 Exploit was tested on: ====================== Thomson Reuters FATCA v5.1.0.30 Description: ============ The Thomson Reuters for FATCA solution enables organizations to comply with the key requirements of both CRS and FATCA.[1] Vulnerabilities: **************** Arbitrary File Upload: ============================================ FATCA users are able to upload any type of file (including PHP scripts) on the server. To successfully exploit this vulnerability it is possible for example to use Directory Traversal in "specid" parameter to upload PHP file to web root of the application and finally execute system commands. References: =========== [1] Overview: https://risk.thomsonreuters.com/products/thomson-reuters-fatca Contact: ======== Jakub[dot]Palaczynski[at]ingservicespolska[dot]pl

References:

https://risk.thomsonreuters.com/products/thomson-reuters-fatca


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top