WordPress Yoast SEO Cross Site Scripting

2016.08.06
Credit: Hammad Shamsi
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-79

#Vulnerability: Stored XSS Vulnerability in Yoast SEO Plugin #Impact: High #Authors: Hammad Shamsi #Company: RHAinfoSEC #Website: http://rafayhackingarticles.net & http://blog.sh3ifu.com/ *Introduction* Yoast SEO (formerly known as WordPress SEO by Yoast) is the most complete WordPress SEO plugin that exists today for WordPress.org users. It incorporates everything from a snippet editor and real time page analysis functionality that helps you optimize your pages content, images titles, meta descriptions and more to XML sitemaps, and loads of optimization options in between. *Proof Of Concept* A stored XSS scripting vulnerability was discovered in Yoast SEO plugin for wordpress. The plugin had built-in blacklist filters which were blacklisting Parathesis as well as several functions such as alert. The following POC bypassed: <img src="z" onerror="prompt&#40document.cookie&#41"> *Impact* The impact of this vulnerability is moderate as in order to trigger this vulnerability, the attacker must have guest author priviledges. This is dangerous especially in case of news related blogs where anyone is allowed to create a guest account and post articles for review. *Remediation* All user supplied input must be sanitized before it is reflected inside the application response. Blacklist must be avoided, instead focus should be made on secure coding. This issue is fixed on 3.4.1 Version on Yoast SEO Plugin https://wordpress.org/plugins/wordpress-seo/changelog/


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2018, cxsecurity.com

 

Back to Top