D-Link DSL-2770L Credential Disclosure

2018.12.23
Credit: Tyler Cui
Risk: Medium
Local: No
Remote: Yes
CWE: N/A

[Vendor] us.dlink.com [Product] D-Link DSL-2770L (version ME_1.01, ME_1.02, AU_1.06) [Vulnerability Type] admin credentials disclosure [Affected Component] Web Interface [CVE Reference] CVE-2018-18007 [Security Issue] An authenticated user can visit the page atbox.htm, for example, http://victime_ip/atbox.htm, and obtain clear text password of user admin at the line: else if(ff.curpd.value != "__password__") location="atbox_pd.htm" [Network Access] Remote via Web Interface [Authentication] Not required [Disclosure Timeline] 2018-06-17: Vendor Notification 2018-06-19: Vendor acknowledgement 2018-10-23: Request update 2018-10-26: Vendor: "I don't have an update currently, but fixes are under development." 2018-12-07: Inform vendor of disclosure 2018-12-17: Public Disclosure


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top