WordPress WPFront Notification Bar 1.9.1.04012 Cross Site Scripting

2021.07.14
Risk: Low
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-79

# Exploit Title: WordPress Plugin WPFront Notification Bar 1.9.1.04012 - Stored Cross-Site Scripting (XSS) # Date: 11/07/2021 # Exploit Author: Swapnil Subhash Bodekar # Vendor Homepage: # Software Link: https://wordpress.org/plugins/wpfront-notification-bar/ # Version: 1.9.1.04012 # Tested on Windows # Category: Web Application How to reproduce vulnerability: 1. Install WordPress 5.7.2 2. Install and activate *WPFront Notification Bar* plugin. 3. Navigate to *WPFront Notification Bar *>> Setting >> notification bar and fill the required data and enter the below-mentioned payload into the Custom CSS user input field. </textarea><script>prompt(1)</script> 5. You will observe that the payload successfully got stored into the database and when you are triggering the same functionality in that time JavaScript payload is executing successfully and we are getting a pop-up.


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2021, cxsecurity.com

 

Back to Top