RSS   Vulnerabilities for 'Comfortel 1200 ip firmware'   RSS

2019-05-29
 
CVE-2018-19978

CWE-119
 

 
A buffer overflow vulnerability in the DHCP and PPPOE configuration interface of the Auerswald COMfort 1200 IP phone 3.4.4.1-10589 allows a remote attacker (authenticated as simple user in the same network as the device) to trigger remote code execution via a POST request (ManufacturerName parameter) to the web server on the device. The web server is running with root privileges and the injected code will also run with root privileges.

 
 
CVE-2018-19977

CWE-77
 

 
A command injection (missing input validation, escaping) in the ftp upgrade configuration interface on the Auerswald COMfort 1200 IP phone 3.4.4.1-10589 allows an authenticated remote attacker (simple user) -- in the same network as the device -- to trigger OS commands (like starting telnetd or opening a reverse shell) via a POST request to the web server.

 

 >>> Vendor: Auerswald 2 Products
Comsuite cti controlcenter
Comfortel 1200 ip firmware


Copyright 2021, cxsecurity.com

 

Back to Top