Vulnerability CVE-2001-0191


Published: 2001-05-03   Modified: 2012-02-12

Description:
gnuserv before 3.12, as shipped with XEmacs, does not properly check the specified length of an X Windows MIT-MAGIC-COOKIE cookie, which allows remote attackers to execute arbitrary commands via a buffer overflow, or brute force authentication by using a short cookie length.

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Andy norman -> Gnuserv 

 References:
http://archives.neohapsis.com/archives/bugtraq/2001-02/0030.html
http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-019.php3
http://www.redhat.com/support/errata/RHSA-2001-010.html
http://www.redhat.com/support/errata/RHSA-2001-011.html
https://exchange.xforce.ibmcloud.com/vulnerabilities/6056

Copyright 2021, cxsecurity.com

 

Back to Top