Vulnerability CVE-2007-1054


Published: 2007-02-21   Modified: 2012-02-12

Description:
Cross-site scripting (XSS) vulnerability in the AJAX features in index.php in MediaWiki 1.6.x through 1.9.2, when $wgUseAjax is enabled, allows remote attackers to inject arbitrary web script or HTML via a UTF-7 encoded value of the rs parameter, which is processed by Internet Explorer.

See advisories in our WLB2 database:
Topic
Author
Date
Low
MediaWiki Cross-site Scripting
Moshe BA
23.02.2007

Type:

CWE-Other

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Mediawiki -> Mediawiki 

 References:
http://attrition.org/pipermail/vim/2007-February/001367.html
http://securityreason.com/securityalert/2274
http://sourceforge.net/project/shownotes.php?release_id=487921&group_id=34373
http://svn.wikimedia.org/svnroot/mediawiki/tags/REL1_9_3/phase3/RELEASE-NOTES
http://www.bugsec.com/articles.php?Security=24
http://www.securityfocus.com/archive/1/460596/100/0/threaded
http://www.vupen.com/english/advisories/2007/0678
https://exchange.xforce.ibmcloud.com/vulnerabilities/32586

Copyright 2022, cxsecurity.com

 

Back to Top