Vulnerability CVE-2016-10436


Published: 2018-04-18

Description:
In Android before 2018-04-05 or earlier security patch level on Qualcomm Small Cell SoC, Snapdragon Mobile, and Snapdragon Wear FSM9055, IPQ4019, IPQ8064, MDM9206, MDM9607, MDM9635M, MDM9640, MDM9650, MSM8909W, QCA4531, QCA9980, SD 210/SD 212/SD 205, SD 400, SD 410/12, SD 425, SD 430, SD 450, SD 615/16/SD 415, SD 617, SD 625, SD 650/52, SD 808, SD 810, SD 820, SD 835, and SDX20, improper input validation infuse read request leads to memory corruption.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Qualcomm -> Sd 400 firmware 
Qualcomm -> Sd 835 firmware 
Qualcomm -> Fsm9055 firmware 
Qualcomm -> Sd 410 firmware 
Qualcomm -> Sdx20 firmware 
Qualcomm -> Ipq4019 firmware 
Qualcomm -> Sd 412 firmware 
Qualcomm -> Ipq8064 firmware 
Qualcomm -> Sd 415 firmware 
Qualcomm -> Mdm9206 firmware 
Qualcomm -> Sd 425 firmware 
Qualcomm -> Mdm9607 firmware 
Qualcomm -> Sd 430 firmware 
Qualcomm -> Mdm9635m firmware 
Qualcomm -> Sd 450 firmware 
Qualcomm -> Mdm9640 firmware 
Qualcomm -> Sd 615 firmware 
Qualcomm -> Mdm9645 firmware 
Qualcomm -> Sd 616 firmware 
Qualcomm -> Mdm9650 firmware 
Qualcomm -> Sd 617 firmware 
Qualcomm -> Msm8909w firmware 
Qualcomm -> Sd 625 firmware 
Qualcomm -> Qca4531 firmware 
Qualcomm -> Sd 650 firmware 
Qualcomm -> Qca9980 firmware 
Qualcomm -> Sd 652 firmware 
Qualcomm -> Sd 205 firmware 
Qualcomm -> Sd 808 firmware 
Qualcomm -> Sd 210 firmware 
Qualcomm -> Sd 810 firmware 
Qualcomm -> Sd 212 firmware 
Qualcomm -> Sd 820 firmware 

 References:
http://www.securityfocus.com/bid/103671
https://source.android.com/security/bulletin/2018-04-01

Copyright 2022, cxsecurity.com

 

Back to Top