Vulnerability CVE-2016-2317


Published: 2017-02-03

Description:
Multiple buffer overflows in GraphicsMagick 1.3.23 allow remote attackers to cause a denial of service (crash) via a crafted SVG file, related to the (1) TracePoint function in magick/render.c, (2) GetToken function in magick/utility.c, and (3) GetTransformTokens function in coders/svg.c.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

Vendor: Debian
Product: Debian linux 
Version: 8.0;
Vendor: Opensuse
Product: LEAP 
Version: 42.1;
Product: Opensuse 
Version: 13.2;
Vendor: Novell
Product: LEAP 
Version: 42.1;
Vendor: Opensuse project
Product: Opensuse 
Version: 13.2;
Vendor: SUSE
Product: Linux enterprise debuginfo 
Version: 11;
Product: Linux enterprise software development kit 
Version: 11;
Product: Studio onsite 
Version: 1.3;
Vendor: Graphicsmagick
Product: Graphicsmagick 
Version: 1.3.23;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00000.html
http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00010.html
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00037.html
http://www.debian.org/security/2016/dsa-3746
http://www.openwall.com/lists/oss-security/2016/02/11/6
http://www.openwall.com/lists/oss-security/2016/05/20/4
http://www.openwall.com/lists/oss-security/2016/05/27/4
http://www.openwall.com/lists/oss-security/2016/05/31/3
http://www.openwall.com/lists/oss-security/2016/09/07/4
http://www.openwall.com/lists/oss-security/2016/09/18/8
http://www.securityfocus.com/bid/83241
https://bugzilla.redhat.com/show_bug.cgi?id=1306148

Related CVE
CVE-2019-11506
In GraphicsMagick from version 1.3.30 to 1.4 snapshot-20190403 Q8, there is a heap-based buffer overflow in the function WriteMATLABImage of coders/mat.c, which allows an attacker to cause a denial of service or possibly have unspecified other impact...
CVE-2019-11505
In GraphicsMagick from version 1.3.8 to 1.4 snapshot-20190403 Q8, there is a heap-based buffer overflow in the function WritePDBImage of coders/pdb.c, which allows an attacker to cause a denial of service or possibly have unspecified other impact via...
CVE-2019-11474
coders/xwd.c in GraphicsMagick 1.3.31 allows attackers to cause a denial of service (floating-point exception and application crash) by crafting an XWD image file, a different vulnerability than CVE-2019-11008 and CVE-2019-11009.
CVE-2019-11473
coders/xwd.c in GraphicsMagick 1.3.31 allows attackers to cause a denial of service (out-of-bounds read and application crash) by crafting an XWD image file, a different vulnerability than CVE-2019-11008 and CVE-2019-11009.
CVE-2019-11010
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a memory leak in the function ReadMPCImage of coders/mpc.c, which allows attackers to cause a denial of service via a crafted image file.
CVE-2019-11009
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a heap-based buffer over-read in the function ReadXWDImage of coders/xwd.c, which allows attackers to cause a denial of service or information disclosure via a crafted image file.
CVE-2019-11008
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a heap-based buffer overflow in the function WriteXWDImage of coders/xwd.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact ...
CVE-2019-11007
In GraphicsMagick 1.4 snapshot-20190322 Q8, there is a heap-based buffer over-read in the ReadMNGImage function of coders/png.c, which allows attackers to cause a denial of service or information disclosure via an image colormap.

Copyright 2019, cxsecurity.com

 

Back to Top