Vulnerability CVE-2020-15863


Published: 2020-07-28

Description:
hw/net/xgmac.c in the XGMAC Ethernet controller in QEMU before 07-20-2020 has a buffer overflow. This occurs during packet transmission and affects the highbank and midway emulated machines. A guest user or process could use this flaw to crash the QEMU process on the host, resulting in a denial of service or potential privileged code execution. This was fixed in commit 5519724a13664b43e225ca05351c60b4468e4555.

Type:

CWE-120

(Buffer Copy without Checking Size of Input ('Classic Buffer Overflow'))

CVSS2 => (AV:L/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.2/10
10/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
QEMU -> QEMU 

 References:
http://www.openwall.com/lists/oss-security/2020/07/22/1
https://git.qemu.org/?p=qemu.git;a=commitdiff;h=5519724a13664b43e225ca05351c60b4468e4555
https://lists.nongnu.org/archive/html/qemu-devel/2020-07/msg03497.html
https://lists.nongnu.org/archive/html/qemu-devel/2020-07/msg05745.html

Copyright 2020, cxsecurity.com

 

Back to Top