RSS   Vulnerabilities for 'Mozjpeg'   RSS

2020-06-03
 
CVE-2020-13790

CWE-125
 

 
libjpeg-turbo 2.0.4, and mozjpeg 4.0.0, has a heap-based buffer over-read in get_rgb_row() in rdppm.c via a malformed PPM input file.

 
2019-03-07
 
CVE-2018-14498

CWE-125
 

 
get_8bit_row in rdbmp.c in libjpeg-turbo through 1.5.90 and MozJPEG through 3.3.1 allows attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted 8-bit BMP in which one or more of the color indices is out of range for the number of palette entries.

 

 >>> Vendor: Mozilla 30 Products
Bugzilla
Mozilla
Firefox
Seamonkey
Thunderbird
Bonsai
Network security services
Camino
Mozilla suite
Durian web application server
Geckb
Libxul
NSS
Gecko
Firefox esr
Thunderbird esr
Firefox mobile
Zamboni
Firef14caox
Netscape portable runtime
Firefoxos
Firefox os
Bleach
Nunjucks
Mozjpeg
Webthings gateway
Pollbot
Hubs cloud reticulum
Mozilla vpn
Nss esr


Copyright 2022, cxsecurity.com

 

Back to Top